Ubuntu 18.04 image has changed the default locale

Avatar mouthwateringmedia 5 months ago

In previous Linode images for Ubuntu, the default locale was en_US.UTF-8. The Ubuntu 18.04 image from Linode is using en_US. Although this may seem like a simple thing to change later on, it can affect how packages are installed. For example, when installing postgresql, it will change the default database encoding from UTF-8 to LATIN1. This will cause database errors.

The /etc/default/locale file should contain:

LANG="en_US.UTF-8"

You can also update it by running the command:

sudo update-locale LANG="en_US.UTF-8"

1 Reply

This was the case for the first few weeks our Ubuntu 18.04 image was available (April 26th, 2018 through May 18th, 2018).

The en_US locale setting was the default provided by Ubuntu Server and no changes were made to use the UTF-8 locale. Due to customer feedback, it was updated to en_US.UTF-8 on the 18th of May. Any Linodes created from the Ubuntu 18.04 image after that date will already have this configured.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct