Copying a Disk Image Over SSH - Estrange behaviour


I am trying to execute a Copying a Disk Image Over SSH using the instructions provided at … e-over-ssh">

The disk image I am trying to copy is Pantheon Mercury

Using Linode's console I run into a few issues:

A) Using Safari on Mac, when trying to set the location of the file, no matter what I try, it always gives me a "No such file or directory", though I set the proper path for my system (/Users/myuser/linode.img). I tried many paths and the only that "appeared" to work was using the root path "/linode.img", but when it was done there was no file to be found anywhere in the system.

B) After that every single try I have attempted ends with a one hour delay in action, then it tells me it executed the action and copied "34 Gigs" !!!!! And of course, no file to be found.

> 66584576+0 records in

66584576+0 records out

34091302912 bytes (34 GB) copied, 1455.89 seconds, 23.4 MB/s

What am I doing wrong? Do I have to use the Linode console to do this or can I use my own terminal?

Thanks in advanced

Post Edit: Doing the same from Ubuntu I get the same result.

9 Replies

Can you give the command you were using to do the copy?

eg - the example said:

ssh -C root@ "dd if=/dev/xvdb" | dd of=/home/archive/linode.img

My hunch is that you got the dd of= part wrong.

You could also install the pv utility. Then you can put eg:

ssh -C root@ "dd if=/dev/xvdb" | pv | dd of=/home/archive/linode.img

… and it will show you the progress as it goes.

There's no need to let it run for an hour without checking to see it's working - you should be able to see the file appearing on your system after only a few seconds.

Thanks on the PV tip…..

the command I use is:

using as example IP

killroy is my username/account in my local Mac OS X laptop

ssh -C root@ "dd if=/dev/xvdb" | dd of=/Users/killroy/linode.img

And I still can't figure out where it got 34 gigs from

On which machine are you executing the command?

As the instructions indicare, I am doing this using the Linode console. (So I am on my laptop)

You are supposed to execute the command on the machine that you want to download the disk image to. You might want to check your Linode now; you could probably find the file "linode.img" through your Linode console now.

Anyway, on the right note, you are supposed to execute the command on your Mac (if it has SSH and dd, which I believe so). The exact command reads: SSH into the specified server, set the file specified as the input file for dd, and pipe it into the output file for dd, which will then be copied to the machine that the command is executed on when the command has been completed.

Alternatively, if you set up a SSH server on your Mac then you could do this through your Linode console, but that would be too much of a hassle.

Ok, I appreciate the help. I guess I should probably not taken the instructions for their word as they clearly instruct to use the Linode console.

Yes, that's what I thought. Thanks man.

The way the instructions read it makes it look like you must use the ajax console for the whole process, but it appears that you only need to use it to set the password for Finnix


I figure all out.

So in conclusion:

A) After starting the Finnix image, use the AJAX console to set password, start ssh.

B) Then switch over to terminal in local machine to execute copy.

The size issue was because I was running a 32 GIG image. Duh.

A funny update: I had forgotten I had actually asked this before months earlier and I was looking for an answer to the same problem. I found this and I was: Weird, this guy has the same problem I do now.

Then I looked at the poster….and it was me.

Can you define embarrassing?


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct