Startup services running twice

This is something I've never seen before, I just rebooted one of my ubuntu 10.04 nodes and noticed all the startup services started twice.

My lish logview looks like this:

Starting apache2
Starting apache2
(98)Address already in use: make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs


 * Starting MySQL database server mysqld        * Starting MySQL database[ OK ]  * Starting nsd3...        * Starting nsd3...       
                                                                         [ OK ]
 * Starting Postfix Mail Transport Agent postfix        * Starting Postfi[ OK ] Transport Agent postfix       
                                                                         [ OK ]
 * Starting NTP server ntpd        * Starting NTP server ntpd            [ OK ] 
Starting daemon monitor: monit.

I checked I don't have duplicate startup links, if I do an update-rc.d -f mysql remove then reboot mysql doesn't start at all, re-adding it still makes is start twice.

The only things in my logs are warnings about everything starting twice.

Has anyone seen this before or have a clue where to poke to find out whats causing it?

3 Replies

Have you played with /etc/init.d/rc ? Maybe the concurrency setting is messing it all up?

Nope not touched it, it's a new linode too only a few weeks old :/ thing is I'm not sure if it's always done this. If all else fails I can try making a new node but meh thats time consuming!

Found the problem, I had a duplicate copy of /etc/init/rc.conf so upstart was running /etc/init.d/rc twice.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct