can't send email from an email client using postfix


I have tried and tried and tried to get email to work by sending from an email client.

However, it keeps giving me this error:

Jan1 21:28:51 mtgames postfix/smtpd[23134]: NOQUEUE: reject: RCPT from[]: 554 5.7.1 : Client host rejected: Access denied; from=<> to=<> proto=ESMTP helo= I'm not quite sure what to do to get this fixed, so any help would be appreciated.

My email client keeps saying the server settings might be incorrect, and a couple other generic error messages.

Thanks for any help,


7 Replies

Can you send/receive mail locally? May want to confirm that first.

Have you set up SASL on the server?

What do you have "smtpdclientrestrictions" set to in

Is your SMTP client set up to authenticate?

In general you will need to set up sasl on the server to be able to authenticate your client before it will allow sending email from a remote client. Otherwise you will be an open relay.


I basically followed everything in the linode library about setting up dovecot and postfix.

I believe my client is set to authenticate, but not exactly sure.

I believe that it is, however.

Not quite sure how i can check for the smtpd restrictions.



Oh yes, and how can I figure out if i can send mail from my local server?

I tried squirrel mail, and that seems to work.

Is there any way to use mailx? I thought it just used the current user, E.G.




Just was wondering if anyone had any idea about this, because it seems I can send email from the local server, but not from my client. I think I've set up sasl, but can't be sure.



P.S. I followed all the steps in the linode library article about dovecot and postfix.


I really am trying to get this done, and to answer everyone's questions again, I believe i can send from the local server, using squirrel mail. I can't send from a remote client, and I believe it is set to authenticate. My settings are:

Logon using cleartext authentication, my server requires authentication, outgoing mail requires a secure connection, port 465.

I think i set up sasl, at least i have some files related to that in my directories.

A program i installed decided to change the database and everything for postfix, so I tried cleaning it up to make both programs happy. It didn't seem to change the sasl settings however, so I had to change those.

This is what it looks like:


auth required user= passwd=* host= db=*** table=emailusers usercolumn=email passwdcolumn=password crypt=1

account sufficient user=

* passwd=** host= db= table=emailusers usercolumn=email passwdcolumn=password crypt=1


pwcheck_method: saslauthd

mech_list: plain login

allow_plaintext: true

auxprop_plugin: mysql





sql_select: SELECT password FROM emailusers WHERE email = '%u'

That looks all correct to me.

Now, the last thing I have to check is to see if my email client is set to authenticate, which I'm almost certain it is. I'm using windows live mail and have the my outgoing server requires authentication checked.

Thanks for any help,



I really need help here.

I really can't see any reason it's doing this, although there actually is no line that says "smtpdclientrestrictions" in




Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct