weird dns problem with wildcard

hello, i set an "* a name" for a domain on linode dns manager,

looks like

A/AAAA Records
Hostname     IP Address  TTL     Options
    97.107.x.x  Default     Edit | Remove
*     x.179.30.x  Default     Edit | Remove
mail     97.107.x.x  Default     Edit | Remove
test1     x.179.30.x  Default     Edit | Remove
test2     x.179.30.x  Default     Edit | Remove
test3     x.179.30.x  Default     Edit | Remove
www     97.107.x.x  Default     Edit | Remove

it worked, for all the subdomains, i'm going to an external server,

pings and www stuff is working but when i'm using subdomain "test" it is not working.

actually, i started to test this stuff with subdomain it wasnt working then tried something different and it worked. now test is still not working, funny ha? :)

3 Replies

Give us the zone file, not a copy/paste of the edit form. Thanks!

Maybe it's because you keep typing the letter x instead of numbers in your ip address?

Perhaps you tried "test" before Linode's DNS servers were serving the new record, and your resolver cached the NXDOMAIN.

But we can only speculate without more information.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct