squeeze and exim4: cannot send mail, errors [SOLVED]

I'm trying to install debian 6 squeeze and exim4 as follows:

1. In linode admin: Deploy a Linux Distribution -> select Debian 6 -> boot linode and login.

2. In putty session, basic config:

[email protected]:~# apt-get update

[email protected]:~# apt-get upgrade --show-upgraded

Setting up acpid (1:2.0.7-1) …

Starting ACPI services….

[email protected]:~# echo "playground" > /etc/hostname

[email protected]:~# hostname -F /etc/hostname

[email protected]:~# vi /etc/hosts

127.0.0.1 localhost.localdomain localhost

109.74.205.143 playground.alexatnet.com playground

3. In putty session, exim4 config, following http://library.linode.com/email/exim/se … -6-squeeze">http://library.linode.com/email/exim/send-only-mta-debian-6-squeeze

[email protected]:~# apt-get install exim4-daemon-light mailutils

[email protected]:~# dpkg-reconfigure exim4-config

typed exactly as instruction recommends, only replaced sample domains with playground.alexatnet.com and playground.

[email protected]:~# echo "This is a test." | mail -s Testing [email protected]

2011-03-01 22:42:02 1Pucws-0000lJ-IJ Cannot open main log file "/var/log/exim4/mainlog": Permission denied: euid=101 egid=103

2011-03-01 22:42:02 1Pucws-0000lJ-IJ <= [email protected] U=root P=local S=405

2011-03-01 22:42:02 1Pucws-0000lJ-IJ Cannot open main log file "/var/log/exim4/mainlog": Permission denied: euid=101 egid=103

exim: could not open panic log - aborting: see message(s) above

Can't send mail: sendmail process failed with error code 1

I've repeated the steps with different values in /etc/hosts, different domains in exim options (redeploy the system each time) - the same error.

Please help.

BTW, I would like to use alexatnet.com as FQDM in /etc/hosts and exim config. Is this possible?

Thanks,

Alex

5 Replies

Small update: i've installed debian in VMWare and installed exim4 successfully.

Thanks,

Alex

Update: creating /var/log/exim4/mainlog fixes the error. exim delivers message correctly now.

Thanks linode support for provided solution.

Regards,

Alex

create /var/log/exim4 didn't work for me. Still looking for a solution.

Best regards,

Fernando

For an existing install, please try issuing the following command:

apt-get install --reinstall exim4-base

After doing so, follow the instructions here to reconfigure Exim: http://library.linode.com/email/exim/se … -6-squeeze">http://library.linode.com/email/exim/send-only-mta-debian-6-squeeze

This issue has been fixed in our base deployment images. Sorry about any inconvenience, and please let us know if you experience any additional difficulties.

Well, for me works with this command lines

chown Debian-exim:Debian-exim /var/log/exim4/mainlog
chmod 700 /var/log/exim4/mainlog

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct