trouble accessing root user

I am having trouble accessing root user

I couldnt find much documentation on 'console access'. I figure it is extra security for ssh.

On the linode manager> console access> Lish via SSH Password

I have inserted a different password, and hit change password.

I didnt load/submit any keys.

Then, on my computer on the terminal I was able to login by using "Lish via SSH" address. However, I had to login one more time as root after I logged in.

I created additional users etc. exit the terminal. Then, I couldnt login using "Lish via SSH Password" I cant even login using my SSH Access. Tried several times. I figured I got locked out as root user. Then, I tried the new user I have created, and I was able to login without a problem.

Then, I found this … py+pub+key">


how can I access root?

2 Replies

Lish gives you remote access to a console which is as if you were psychically in front of the machine, hence you need a user name and password to log in.

If you granted one of your new users sudo access you can log in with that and type sudo -i to get into a root shell.

If not and you've totally locked yourself out of your root account, shutdown the linode then click the rescue tab in the linode manager and you can change the root password there.

Some distributions disable the root account in favour of using sudo from a regular user account. Something to keep in mind.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct