white blank screen on the site

Starting around 11:30am I usually get white blank screen. The site loads nothing but a empty white screen. You cant use ssh around that time either. So, I reboot, and it always worked, except today.

The only things that looks unusual is that outgoing traffic shoots up close to lunch time.

How can I solve this issue?

thank you.

3 Replies

What are you running on your server? Apache? nginx? PHP? WordPress? Any plugins? Find error logs for your server of choice, and look for anything that might help.

What does the I/O graph look like when ssh becomes unresponsive and outgoing traffic spikes? You might be running out of memory because of too many concurrent users.

Can you use Firebug or Chrome Webmaster Tools (depending on your browser) to grab the HTTP headers of the empty white screen? It might say something like "HTTP/1.1 500 Internal Server Error" followed by a bunch of other lines to help diagnose problems.

Yes, it is 500 error.

HTTP Headers

Response HTTP/1.1 500 Internal Server Error

Date Fir, 22 jul 2011 20:54 GMT

Server Apache/2.2.14(ubuntu)

Vary Accept-Encoding

Expires Wed, 11 Jan 1984 05:00:00 GMT

Last Modified Fri, 22 Jul 2011 20:54:02 GMT

Cache-control no-cache, must-revalidate, max-age=0

Pragma no-cache

Conent-Encoding gzip

Content-Length 20

Connection close

Content Type text/html;charse=utf-8

I am on apache, wordpress. I dont have APC installed.

As, I was setting up the server. At one point, I installed APC, by doing

apt-get php5-cli php5-cgi php5-dev php-apc. Then, installed webalizer, and checked the site. Again, it

was white screen.

No error, no log issues. I backtrack uninstall webalizer. Then, it was still blank screen. I uninstalled APC, left php5-cli php5-cgi php5-dev as is… Reboot the server, and the site was up.

outgoing traffic is avg: 150 kb/s and right before lunch time shoots around 1.5 Mb/s

In the beginning, before I used http://library.linode.com/troubleshooti … networking">http://library.linode.com/troubleshooting/memory-networking

the IO rate used to go up and down. After using the low-memory settings, I was able to bring it down

IO Rate around 5 to 15.

However, it sometimes shoots up like crazy during lunch time. It averages around 536. The graph shows as high as 4808, I think this was before the low-memory settings.

free -m

total used free shared buffers cached

Mem: 497 194 302 0 16 110

-/+ buffers/cache: 67 430

Swap: 255 0 255


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct