Enforcing SELinux on CentOS 6 image

[root@li215-102 ~]# selinuxenabled &
[1] 1857
[1]+ Exit 1 selinuxenabled
[root@li215-102 ~]# cat /etc/selinux/config

This file controls the state of SELinux on the system.

SELINUX= can take one of these three values:

enforcing - SELinux security policy is enforced.

permissive - SELinux prints warnings instead of enforcing.

disabled - SELinux is fully disabled.


SELINUXTYPE= type of policy in use. Possible values are:

targeted - Only targeted network daemons are protected.

strict - Full SELinux protection.

[root@li215-102 ~]# setenforce 1
setenforce: SELinux is disabled
[root@li215-102 ~]#


It seems that SELinux is being disabled when the linode comes up by a boot parameter, despite the config file setting and rebooting. As a linode, I don't have access to the equivalent of /etc/boot/grub.conf to fix it.

How do I enable SELinux on my CentOS 6 image?

1 Reply

Boot CentOS kernel instead of Linode's.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct