ufw missing in new Ubuntu images???

For some reason when I install a new image of 10.04 or 11.04 of ubuntu, there is no ufw. When I searched for "ufw" there is a ufw directory in /etc but nowhere is there a binary. When I tried installing ufw using aptitude on 10.04 it mentioned something about a corrupt ubuntu image. I had just rebuilt using a new 10.04 imagefrom the Linode Manager so I don't see how that can be.

What am I missing here?

5 Replies

What's the exact error you get when you try to install it? Are you running 'apt-get update' (or whatever the Aptitude equivalent is) first? Ubuntu doesn't include ufw in the minimal installation, but it should install just fine.

I just did another fresh install of 10.04 using the Linode Manager, I did:

apt-get update

apt-get upgrade –show-upgraded

no errors.

When I try ufw after all that:

-bash: ufw: command not found

It was my understanding that ufw was installed by default. I have 9.04 running on another instance and do not recall having to install it separately. That is why I am wondering.

Ok, I went with the basics and did:

apt-get install ufw

And that correctly installed it.

When I use aptitude and select the ufw package from there it acts like it is reinstalling the ubuntu image and you get lots of errors.

Although UFW has been gaining traction among Ubuntu users, it is still not considered part of a standard Linux stack, and it may never be (because there are other firewalls, too). So it's not surprising that it got left out.

Also, some OS images are more bare-bones than others. Some VPS companies (not Linode) even supply CentOS images without yum. That's crazy.

Technically speaking, iptables isn't even part of the Ubuntu base installation:

rtucker@witte:~$ apt-cache showpkg ubuntu-minimal
Package: ubuntu-minimal
1.197 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_lucid_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_lucid_main_binary-amd64_Packages
                  MD5: 790932f14543314e43c3705a3451df24

Reverse Depends: 
1.197 - adduser (0 (null)) apt (0 (null)) apt-utils (0 (null)) bzip2 (0 (null)) console-setup (0 (null)) dash (0 (null)) debconf (0 (null)) dhcp3-client (0 (null)) eject (0 (null)) gnupg (0 (null)) ifupdown (0 (null)) initramfs-tools (0 (null)) iproute (0 (null)) iputils-ping (0 (null)) kbd (0 (null)) less (0 (null)) locales (0 (null)) lsb-release (0 (null)) makedev (0 (null)) mawk (0 (null)) module-init-tools (0 (null)) net-tools (0 (null)) netbase (0 (null)) netcat-openbsd (0 (null)) ntpdate (0 (null)) passwd (0 (null)) procps (0 (null)) python (0 (null)) rsyslog (0 (null)) sudo (0 (null)) tasksel (0 (null)) tzdata (0 (null)) ubuntu-keyring (0 (null)) udev (0 (null)) upstart (0 (null)) ureadahead (0 (null)) vim-tiny (0 (null)) whiptail (0 (null)) 
1.197 - 
Reverse Provides: 

That's not to say that the Linode base image doesn't digress from ubuntu-minimal (eject is removed and openssh-server is added, for two examples), but it's clearly inspired by it.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct