Can't understand why my Linode is so slow

Hi. I've read through countless threads on here regarding Apache configuration and slow page loads but nothing I do seems to help.

My Linode 512 is hosting this Wordpress site: http://www.corstorphinehill.co.uk

It's not getting much traffic.

Sometimes, maybe every 15th page, it will take the page up to 40 seconds to load. It seems to spend a lot of time "waiting for website" in Firefox.

My YSlow score is Grade A (93/100)

My PageSpeed score is 95/100

I've ruled out my firewall (ufw) by temporarily disabling it. The load never seems to spike. I'm at a bit of a dead end. Can anyone please help? Is there any way to tell exactly why my browser is waiting?

Here's my apache config:

ServerRoot "/etc/apache2"
LockFile /var/lock/apache2/accept.lock
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive Off
MaxKeepAliveRequests 100
KeepAliveTimeout 2
 <ifmodule mpm_prefork_module="">KeepAliveTimeout 2
StartServers 5
MinSpareServers 5
MaxSpareServers 5
MaxClients 20
MaxRequestsPerChild 1000</ifmodule> 
 <ifmodule mpm_worker_module="">StartServers          1
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          8
    MaxRequestsPerChild   0</ifmodule> 
 <ifmodule mpm_event_module="">StartServers          1
    MaxClients          8
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxRequestsPerChild   0</ifmodule> 
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
AccessFileName .htaccess

 <files ~="" "^\.ht"="">Order allow,deny
    Deny from all
    Satisfy all</files> 
DefaultType text/plain
HostnameLookups Off
ErrorLog /var/log/apache2/error.log
LogLevel warn
Include /etc/apache2/mods-enabled/*.load
Include /etc/apache2/mods-enabled/*.conf
Include /etc/apache2/httpd.conf
Include /etc/apache2/ports.conf
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
logfile
CustomLog /var/log/apache2/other_vhosts_access.log vhost_combined

Include /etc/apache2/conf.d/
Include /etc/apache2/sites-enabled/

20 Replies

Note also that the last URL posted in this thread was in May of this year, some months ago.

(Are folks forgetting to set their KeepaliveTimeouts to 1 second or so?)

Been experimenting with KeepAlive on. Doesn't seem to help :cry:

I've tried reloading your site quite a few times and haven't noticed it loading slowly. Could it be network related? Try a ping -t and see if you're getting some slow pings or timeouts.

I loaded the site over 20 times too and no noticeable delay for me. Did you try using a different browser? One of the newer Firefox's did that to me with a website routinely. That why I still use 3.6 :evil:

I loaded several times as well, it works fine for me.

James

And again from a different IP address 8). From my experience, I'd say your site is quite fine.

Thanks all for trying. I'm very reassured that nobody thinks it's slow!

I think the problem might only be evident if I'm logged in to Wordpress, although it seems OK today. I'll do some more experimenting.

Thanks again!

@DrookitMunter:

I think the problem might only be evident if I'm logged in to Wordpress, although it seems OK today. I'll do some more experimenting.
I don't know WordPress specifically, but it wouldn't be surprising if caching was largely or completely disabled for logged-in users.

Can't see any issues from my end.

https://developers.google.com/pagespeed … bile=false">https://developers.google.com/pagespeed/#url=http3A2F2Fwww.corstorphinehill.co.uk2F&mobile=false

Yip I'm pretty certain now that this is only happening when users are logged in. So this is a Wordpress problem rather than a configuration problem.

Thanks for everyone's help and input, it's appreciated :)

The page IS a bit heavy.

  • front page has three 150kb images in the slideshow

  • google analytics(13kb) and google pagespeed(54kb) and facebook js(43kb) loading in the head and 170kb of other facebook js loading later

  • 3 web fonts

It looks nice, but it's not exactly built for speed.

http://loads.in/waterfall.php?inputUrl=gethar.php%3Flogid%3D491556

Just to let you know, I loaded the front page a few times and I ended up getting a logged in page for DrookitMunter. I didn't actually have admin access, but you should check that you have your caching system properly configured, because it's caching admin users.

/category/blog/ seems to be the most likely page to lag.

http://loads.in/waterfall.php?inputUrl=gethar.php%3Flogid%3D491605

These things are tough to track down. Unfortunately, the tools are pretty technical. xhprof for profiling, mysql slow query log and EXPLAIN if it's in the database query. I've heard good things about New Relic free trial.

You might want to go through your wordpress modules and research each one and see if others are having problems with any.

Thanks for the tips and thanks for warning me about the logged in as admin thing - worrying! I believe that's fixed now

Yeah http://corstorphinehill.co.uk/category/blog/ is slow for me.

Every refresh takes about 20 seconds.

@bradleyg:

Yeah http://corstorphinehill.co.uk/category/blog/ is slow for me.

Every refresh takes about 20 seconds.
It took a LONG time to load for me initially but then refreshing was just as fast as could be. The first load though was at least 30-45 seconds if not more.

All loads of http://corstorphinehill.co.uk/category/blog/ is take 20-30 seconds for me, the network analysis in chrome states that it's waiting during this point, I'd point the finger at Wordpress/PHP/MySQL.

Try disabling all wordpress plugins and themes and see if it fixes it, if it does enable each theme and plugin one by one and re-test until it goes slow again then you'll have found the culprit.

I tried that site obs listed, 23 seconds to load here, the whole wait on the first GET. Then I added index.html and it came back immediately with an error.

As obs said, it looks like a configuration problem in the web app software, not a Linode issue, but that's just my opinion.

Edit: PS My sites are done in GWT and they run fine.

OMG i tried your site and it has the exact same problem as mine !

I also hired linode 512, and is taking around 20 seconds to load !! fucking insane, then when the client is connected is lighting fast, i think this problem is not related to our apache configuration instead is related to linode networking itself, and we can't do nothing about that !

i will make a support ticket about this ASAP, i am losing clients…

I'm confirming that it's also slow for me from Massachusetts, USA. It takes about 20 seconds to download/start rendering the first page. I went to the About us page and that also took several seconds to load. If I try loading the contact us page while "about us" is still waiting to connect and "about us" starts downloading, the contact us page downloads at the same time (that is, once the connection is established, both pages download simultaneously instead of there being a fixed amount of time between click and download).

>> Note also that the last URL posted in this thread was in May of this year, some months ago.

So? The problem is still reproducible.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct