StackScript : no output

Hi all,

I'm trying to implement my own StackScript.

I have tried with the linode deploy tool but it seems there is something wrong because some stuff is not well set up, after build.

The problem is I can't see what's happen during I launch it. As mentioned in this post: ~~[" target="_blank">]( … tackscript">](.

I logged myself on the console through the lish connection to see what's going on the console. But nothing appears on it except :

Job XXXXXX - System Shutdown completed.
Job XXXXXX - Disk Delete - [866160] completed.
Job XXXXXX - Disk Create From StackScript completed.
Job XXXXXX - Create Filesystem - 256MB Swap Image completed.

Even if I have in my StackScript this piece of code : echo 'Create RVM group'
At the beginning of my script, I put set -e as mentioned in this thread: ~~[" target="_blank">]( … tackscript">](

Is there a way to see what really happen during this execution :?:

Thank you for your time !

2 Replies

To reply to my own post, I rebuild and now it works.

Maybe, during my previous tries, I was not well connected.

My bad, sorry. :oops:

I just ran into this and have a fix that works for me and might help others.

 #!/bin/bash -e
 exec > >(tee -i /var/log/stackscript.log)
Top of StackScript with output logging
  1. Create instance with the StackScript changes above.
  2. Once the console shows "Running"
  3. Launch Console
  4. Glish
  5. Login as root
  6. tail -f /var/log/stackscript.log


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct