Trying to set up public key. User password rejected.

Nevermind, solved– apologies if anyone took time considering this. Established the user wrongly. Was much easier than I was making it out to be. Just useradd. And then there was an issue with the folder permission. Noob error.


I'm trying to set up a public key.

I generated one locally, and am now trying to copy it to my linode.

When I do so, it prompts me for the user's password, which I enter-- but it keeps rejecting me.

The user I set up has a home folder and a password.

I tried to log in as the user, which also failed.

When I checked /var/log/auth.log I found this for each login attempt:

Failed password for <>

But there's no question that I typed the password correctly. I tried a bunch of times and changed the password to a very simple four number sequence just to make sure there were no mistakes.

I rebooted after adding the new user, too.

Any ideas? I'm running Apache on Lucid.

Any help would be very much appreciated.

0 Replies


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct