Citadel permission denied


I am new to the whole concept of setting up a web server, at least in practice, but have been a linux user for quite some time.

I have followed all the guides so far to setup my linode, with Debian squeeze. The Apache2 server is installed, so too postgresql and php5. Everything went well after some days installing and troubleshooting minor things.

Now came the time to setup my mail server. Chose Citadel to do the job. So far the installation was fine.

But I am up to this point:

"Configure SSL" in the … -6-squeeze"> help file.

The problem is I cannot as my user (I am not using root) access the /etc/ssl/citadel folder. I can access etc and ssl but when I try to access citadel it says:

vanir@freja:~$ cd /etc/ssl/citadel

-bash: cd: /etc/ssl/citadel: Permission denied

The permission denied only comes up for the citadel folder.

I would appreciate some assistance so that I can continue with the installation of the Citadel server. I am sure it is something very easy that I am overlooking, so please excuse my noviceness.

Greetings and many thanks in advance,


10 Replies

try these commands to compare the directory permissions:

ls -l /etc

ls -l /etc/ssl

ls -l /etc/ssl/citadel


Thank you James, I will try it.

Hi James,

I tried what you suggested. I could see information inside the /etc and /ssl folders, but it did not list or show anything in the /citadel folder, it came up with the same error, that permission is denied.

Do you have another suggestion what I could do? Should I paste something here to view?



It's quite common for ssl certificates for applications to be only accessible by root (so no one else can read them), so prefix your commands with sudo.

The problem is then the permissions for sure. Try using the commands as root, or prefix with sudo as obs suggests above, to see the existing permissions.


Hi again,

About sudo and root, that is what I tried before I posted my problem to this forum. I have disabled root as per the security settings.

Sudo doesnt work in my case. The error that comes up is:

vanir@freja:~$ sudo cd /etc/ssl/citadel

[sudo] password for vanir:

sudo: cd: command not found

Shall I try as root and reenable root permissions in the settings?

Thank you again for your help.


sudo -i will bring you into a root shell without having to enable root, try that.

Thank you that was very helpful. :)

It worked, using sudo -i …

I was able to do what was required in the citadel folder…

As per the installation instructions here: … figure-ssl">

I tried the next step of:

"Commercial Certificate Instructions"

but came up with the following error:

root@freja:/etc/ssl/citadel# openssl req -new -nodes -newkey rsa:4096 -days 365 -keyout citadel.key -out citadel.csr chmod 600 citadel.key

unknown option chmod

req [options] outfile

where options are

… followed by a long list of info …

I don't know why this problem is coming up and so searched for a solution in the Linode Library and came up with two possible help files: … an-5-lenny">

which is "Help to get get up and running quickly with SSL for Apache on your Linux VPS".

and … commercial">

which is "Obtaining a Commercial SSL Certificate"

I was hoping someone could tell me which help file could help me move forward?

Thank you again,


> root@freja:/etc/ssl/citadel# openssl req -new -nodes -newkey rsa:4096 -days 365 -keyout citadel.key -out citadel.csr chmod 600 citadel.key

unknown option chmod

Those are two commands so run

 openssl req -new -nodes -newkey rsa:4096 -days 365 -keyout citadel.key -out citadel.csr

Followed by

chmod 600 citadel.key

Thank you for pointing out the obvious :) Brain didn't register the two lines of code as being separate. Of course it worked. Many thanks again.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct