Last Modified Date Reflects Upload Rather Than Modified Date

Good morning,

Ever since I upgraded my Debian Linode to Squeeze, I'm having an unusual issue. I typically do file uploads to my Linode using SFTP, and in the past, doing such an upload would keep the Last Modified Date on the file the same as it was on my local system. However, since the upgrade, I note now that the Last Modified Date reflects the time and date of upload, not of last modification.

Does anyone know how to correct this behavior? I actually use the Last Modified Date in my website, and need it to reflect the modification rather than upload date. I've ruled out my local client by trying other clients and experiencing the same behavior, leading to the conclusion that the server is at fault.

Thank you.

  • Trip

4 Replies

sftp (and scp) has a -p flag: "Preserves modification times, access times, and modes from the original files transferred"

I spotted that, but I don't typically use the command line utility, as it would be much too time consuming versus drag and drop. I use Konqueror, and also tested with FileZilla. I've never had this problem before.

Thank you.

  • Trip

Try running scp with -vvv on the command line (with and without -p) and see if you get any useful debug messages.

I was able to get some information out. Essentially, with -p, it is clearly and distinctly sending along the timestamp, while without it, it does not. I'm betting, now, that it actually is a client issue, or at least, an issue that should be fixable on the client side. Off to learn more about KIO slaves.

Thank you.

  • Trip


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct