Cannot run yum commands

Hi all,

Yesterday I ran the "yum cleanall" command because WHM could not find any package. Now I cannot run any yum commands at all. For example:

yum update yum makecache yum upgrade

All of these fail and return an error like this:

yum update

Loaded plugins: universal-hooks Could not retrieve mirrorlist error was 12: Timeout on (28, 'Connection timed out after 30006 milliseconds')

One of the configured repositories failed (Unknown), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=<repoid> ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>
        subscription-manager repos --disable=<repoid>

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: EA4

I have tried: Changing the DNS servers Uncommenting the baseurl in the mirrorlist About 5 hours of other things tinkering

Does anyone know what I am doing wrong?

Thanks in advance for any help, I really appreciate it.

1 Reply

Hey there,

You're not doing anything wrong from your end. It appears that the cPanel repository is unable to be resolved, causing Yum to fail on any command. The temporary solution would be to temporarily disable the cPanel repository, moving it from /etc/yum.repos.d/ and backing it up.

For a more permanent fix, it'd be best to reach out to cPanel support and determine if they can provide updated repository information that you could enter into mirrorlist.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct