kernel: swapper/0: page allocation failure

Avatar forum:eld101 6 years, 6 months ago

Every once in a while I was getting these OSSEC notifications (see below) and just played them off. Well the other day while downloading a backup to my PC I was getting them every few minutes. I rebooted and tried again….same thing….they would come in every few minutes.

I am running: CentOS 5.5 Profile (Latest 3.5 (3.5.2-linode45)) … I did some searching and saw some people had a similar issue a while back but supposedly upgrading the Kernal fixed it :/

Any ideas?

OSSEC HIDS Notification.
2012 Sep 30 09:35:11

Received From: cathode->/var/log/messages
Rule: 1002 fired (level 2) -> "Unknown problem somewhere in the system."
Portion of the log(s):

Sep 30 09:35:11 cathode kernel: swapper/0: page allocation failure: order:4, mode:0x20

 --END OF NOTIFICATION

4 Replies

There's a long thread on it here http://forum.linode.com/viewtopic.php?f … allocation">http://forum.linode.com/viewtopic.php?f=20&t=7805&hilit=page+allocation the general solution is to increase vm.minfreekbytes to a minimum of 4096 (I had to go as far as 8192 on one server)

From what I understood, I need to make that change in /etc/sysctl.conf but that does not even exist in there…. nothing close to it even. Do I just need to add it all together, or am I still missing something?

Add it in at the end of the file and then run "sysctl -p" to apply it.

Pages to help your familiarity with sysctl and it's features.

~~[http://www.centos.org/docs/5/html/DeploymentGuide-en-US/s1-proc-sysctl.html" target="blank">](http://www.centos.org/docs/5/html/Deplo … ysctl.html">http://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-proc-sysctl.html](

~~[http://www.centos.org/docs/2/rhl-rg-en-7.2/s1-proc-sysctl.html" target="_blank">](http://www.centos.org/docs/2/rhl-rg-en- … ysctl.html">http://www.centos.org/docs/2/rhl-rg-en-7.2/s1-proc-sysctl.html](

Hope this helps.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct