Postfix, Dovecot not logging on Ubuntu 12.10

I have tried going through the guide to setup mail on 10.04 at ~~[" target="_blank">]( … 0.04-lucid">]( but got stuck around the dovecot stage.

Initially i got errors (through virtualmin) but now i get

telnet pop3
Connected to
Escape character is '^]'.

Although when i look in /var/log/mail.log the file is empty. I have tried adding lines to rsyslog.conf and syslog.conf but nothing gets it working.

Anybody else having trouble, starting to wish i had setup on 10.04 now

6 Replies

I am having the same issue.

Support has not been able to provide me with more help.

anyone has any idea what to do???

I ended up starting another linode from scratch on 10.04 LTS. Just got apache and mysql on then just ran virtualmin installer and all dovecot/postfix installed no problem.

Found from reading around that the mysql alias method in the linode tutorials doesnt seem to be that popular with sys admins

There are some guides which might help with debugging if you're still seeing issues:

I saw this too on a fresh install after installing the 12.10 image, and then installing Postfix. Nothing, no logs. Didn't dig into it deeper as I was just playing around on a new Linode to try a few things out. But I did quickly check on the 12.04 image and there are logs.

So I think there is either an issue with the rsyslog / postfix config in the distro, or a problem with Linode's image for 12.10?

I had the same problem. Turns out some of the key mail-related logs were owned by messagebus and not syslog. chown seems to have fixed the issue.

I ran into the same issue. The previous poster is correct.

For anyone researching the command to run is:

sudo chown syslog.adm /var/log/mail.log

sudo chmod 640 /var/log/mail.log


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct