Longview: Errors starting longview CentOS 6.4 x64

Recently Longview stopped working. I can not find anything that would explain the issue. It installed ok and was running until a reboot this morning (scheduled maintenance). I tried to uninstall and generate a new key then reinstalled, but it still does not start up. Longview was installed after all the repos were added and a "yum upgrade" was performed. There were some updates this morning, but those did not seem to have anything that should have broken longview…

OS: CentOS 6.4 x64

output of lsb_release -a

LSB Version:    :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID: CentOS
Description:    CentOS release 6.4 (Final)
Release:        6.4
Codename:       Final

Error output

[[email protected] Linode]# service longview start
Starting longview: Can't locate JSON/PP.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /opt/linode/longview /opt/linode/longview/lib/perl5 /opt/linode/longview/lib/perl5/x86_64-linux-thread-multi/ /opt/linode/longview/usr/include) at /opt/linode/longview/Linode/Longview.pl line 44.
BEGIN failed--compilation aborted at /opt/linode/longview/Linode/Longview.pl line 44.

I do use some third party repos:

Loaded plugins: aliases, auto-update-debuginfo, changelog, dellsysid,
              : downloadonly, fastestmirror, filter-data, fs-snapshot, keys,
              : list-data, local, merge-conf, post-transaction-actions, presto,
              : priorities, protectbase, ps, remove-with-leaves, rpm-warm-cache,
              : security, show-leaves, tmprepo, tsflags, upgrade-helper, verify,
              : versionlock
Loading mirror speeds from cached hostfile
 * Webmin: download.webmin.com
 * base: linux.mirrors.es.net
 * centosplus: linux.mirrors.es.net
 * contrib: linux.mirrors.es.net
 * epel: linux.mirrors.es.net
 * extras: linux.mirrors.es.net
 * remi: mirrors.mediatemple.net
 * rpmforge: mirror.webnx.com
 * rpmforge-extras: mirror.webnx.com
 * updates: linux.mirrors.es.net
0 packages excluded due to repository protections

repo id         repo name                                                 status
Webmin          Webmin Distribution Neutral                                  144
_local          Automatic local repo. (manged by the "local" yum plugin).    174
base            CentOS-6 - Base                                             6381
centosplus      CentOS-6 - Plus                                               28
contrib         CentOS-6 - Contrib                                             0
epel            Extra Packages for Enterprise Linux 6 - x86_64              8629
extras          CentOS-6 - Extras                                             12
longview        Longview Repo                                                 20
remi            Les RPM de remi pour Enterprise Linux 6 - x86_64             996
rpmforge        RHEL 6 - RPMforge.net - dag                               4593+1
rpmforge-extras RHEL 6 - RPMforge.net - extras                             678+7
updates         CentOS-6 - Updates                                           599
repolist: 22254

Items updated this morning:

Apr 30 02:15:40 Updated: libuuid-2.17.2-12.9.el6_4.3.x86_64
Apr 30 02:15:40 Updated: libblkid-2.17.2-12.9.el6_4.3.x86_64
Apr 30 02:15:41 Updated: util-linux-ng-2.17.2-12.9.el6_4.3.x86_64
Apr 30 02:15:42 Updated: openldap-2.4.23-32.el6_4.1.x86_64

6 Replies

Check that you have the perl-JSON package installed.

perl-JSON is already installed.

Installed Packages
perl-JSON.noarch                       2.50-1.el6.rfx                    @_local
perl-JSON-Any.x86_64                   1.22-1.el6.rf                     @_local
perl-JSON-XS.x86_64                    1:2.27-2.el6                      @_local

You're using the rpmforge version instead of the standard CentOS version. That might be the problem. Try using the stock package.

I also had this issue recently and it was resolved with the help of StanTheMan on IRC. This is a temp fix while they evaluate if the change should go into the next version or not.

edit the Longview.pl located in

/opt/linode/longview/Linode

find line 44, which has "use JSON::PP;"

and change it to "use JSON;"

then restart the service.

BTW: It is definitely something caused by one of the additional repos. I tested a new/different node with the base repos and did not have an issue. The machine that had the problem had all the same repos as you except for Remi and Webmin.

Followed the post by TeddyR42 and it worked… So thanks StanTheMan and TeddyR42.

As for the rpmforge repo, there are MANY that use it since it contains several popular packages that are not available elsewhere… So the choice is either build them myself (thus breaking things worse) or use rpmforge (or even another repo that may be a much bigger risk).

I hope that the change makes it to the next Longview update, but at least for now its working… :-)

We'll be pushing this fix in the next version of Longview and will announce it in #linode-beta. The Linode Manager will also let you know that an update is available.

You're welcome likeaboss and TeddyR42!

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct