Wordpress permission denied to /blog/ folder

Good evening,

The web site I am working on is here:


I have a Debian Squeeze 6 LAMP install.

I am using the latest version of WP.

My VPS had a problem, so I transferred all my WP sites from their live sites to a local install on my laptop. I did this by saving wp-contents and sql backup, etc. After fixing my VPS and rebooting, I am starting to upload or put back all live sites.

I started with one - the site above.

I installed a fresh WP, then transferred wp-content back and imported the sql file. ALl went well, except for a little permalink problem which I ironed out with the Override All setting my sites-available default and default-ssl files. Then activated a2enmode rewrite on the server (i have apache2).

Ok, everything worked wonderfully, except when I try to access the blog page on http://www.mallacootahoney.com

My wp installation is at http://www.mallacootahoney.com/blog and I changed the www link to be http://www.mallacootahoney.com inside WP settings. I transferred the index.php out of blog/ and into the root. So far so good.

In my .htaccess file in the root is only the permalink info. NOthing else.

I have been reading every post on this support forum and also off site courtesy of google. anything that brings up a hint of info about why /blog is being blocked.

I added to my mallacootahoney.com file on apache under the sites-available directory the following code:

Options FollowSymLinks

AllowOverride All

THis is within the Virtual Host comments. When I dont have this code you are able to access blog/ but you can see the entire wp installation directory, which isn't good. When I have the above code, permission is forbidden.

Now when I go into the dashboard and to the page edit of the actual page called blog with the slug also called blog, so it looks like http://www.mallacootahoney.com/blog, and I change the slug name from blog to news, for example, and save it, then the blog shows up as per normal and I can visit all blog posts.

As an aside, in the settings in WP, the Blog page is set as the page where all posts show up.

I understand that somehow there is a conflict between blog/ being recognised as both the WP installation directory and also the location of the web sites posts, so the actual blog. I know that I can solve this problem easily by changing the slug to anything other than blog.

But I would like to know, before using this option, is there another option and what am I missing here. I would really appreciate help and asisstance, as I have spent days trying to fix this problem and I am a little at the end of my abilities here.

Thank you in advance to anyone who can help me and shed light.



1 Reply

Thankfully I solved this after playing around for several hours trying stuff out.

I realised I had used sudo to make the mallacootahoney.com folder when following the instructions in the Configuring Name-based Virtual Hosts info. Therefore I had to sudo the name change from wordpress to blog as the install folder. Therein the problem as it was locked out.

Removed the entire virtual host install and redid it this time without sudo. Made all the difference.

Hope this helps someone else.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct