Problem with virtual host


I'm having a problem with one of my websites, and I was wondering if anyone might know offhand why I'm having issues. I have three websites on my Linode, and up until July 1st they were all working fine. However, now when trying to reach one of my websites, I instead reach another one of the websites located on the same server. The default virtual host is not active, and the virtual host files have the correct permissions, and are in the right place. My third website is also still reachable.

Again, nothing was changed from the working configuration. I'm pulling my hair out over this, so any help would be appreciated! :D


11 Replies

I'm pretty sure the Flying Spaghetti Monster is getting ready to smite you, and this is the first sign.

We require more details than this to properly diagnose your problem. .conf files, sites-available/sites-enabled listings (if apache), etc.

I don't believe in the Flying Spaghetti Monster. He requires too many sacrifices for my taste.

I'm happy to share any details you require. What .conf files/details would you like? The sites-available/sites-enabled listings are correct (AFAIK), so I'm fairly sure that's not the problem, although I'll get you whatever info will move things along.



Please provide a little more information. Don't be shy about including your domain names (that is a subtle hint) because it's next to impossible for us to replicate the issue without them.

Also, have you changed anything on your server between July 1 and when this problem occurred? Updated a config file? Maybe fixed something in an htaccess file? Added a new IP address? Changed your DNS servers? Anything you've done could be the culprit (these computer machines are finicky things).


Nope, nothing was changed. Certainly no .htaccess files or .conf files. DNS servers are still setup and working (this took me forever to figure out, as I'm kinda stepping in to help someone, and whoever setup their myriad sites is directing things all over hell's half acre).

The website that I'm having a problem with is It redirects to, which is on the same server. What's weird (to me at least, as I'm comparatively a noob) is that is still reachable. The sites-available and sites-enabled files are all in order (I think; the file is identical to the other sites' files save for the corresponding info for each site).

I really, really appreciate you taking the time to have a look at this. Beers are on me.


I really, really appreciate you taking the time to have a look at this. Beers are on me.

Only if you provide all your vhosts in sites-enabled can anyone help.

So works fine, works fine, but is now redirecting to

Your IP ( displays, so it could be that isn't configured correctly and therefore displays the default domain for your server.

And you haven't made any changes to anything on your server? worked properly as recently as July 1? Have you restarted your server? Do you get any errors when you restart your httpd service? What do your Apache logs show when accessing


I'm happy to share any details you require.
Why turn your post into a boorish thread of "twenty questions".

Just post ALL THE FREAKING DETAILS so that people can understand what your setup is and hopefully spot the problem.

Don't "assume" anything is ok, because if it was, it would be working instead of being broke.

Better Details = Better Answers

I'm not trying to be deliberately vague, I just don't know what info is required. I didn't set these sites up, and I'm obviously a noob with Linux servers.

A couple of things: the server was rebooted, but only after things stopped working (July 6th, I believe). As for the logs, the access log doesn't list anything after June 30th, which is how I (perhaps incorrectly) deduced that the site stopped working on July 1st.

/etc/apache2/httpd.conf file is empty. I can't run httpd from the command line (it's a daemon, but I should be able to call it from the command line, no?)

Sites-available folder: 000defaultTRW default default-ssl

Again, I appreciate the help.

I figured out my problem. I was actually looking at the wrong files: the default config file was still linked in my sites-enabled folder, even though "a2dissite default" repeatedly reported success, stating "Site default already disabled". Turns out the default config was still running, as the actual default configuration file was not named in the standard way (guessing here). So, even though a seasoned pro (or savvy amateur) would have noticed the file starting with 000 as the default and unlinked it in sites-enabled, I relied upon the above command, which told me that the default config was not running.

Thanks to everyone who tried to help. At the very least, I have a better understanding how everything works, and what to include when asking for help in the future.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct