disk quotas and how to fix them.

Hi all, I would like to enable dis quotas for my server and this is what I did so far. so, I have installed quota by doing apt-get install quota and all is working there. now here is the funny part. I have used webmin to get everything configured for disk quotas even getting them ready for the /dev/xvda device. but when I go to enable the quota in the webmin modules it doesn't do it… Further more, I can't run my quota check -a command because it would just say, "unable to stat /dev/root, no such file or directory." Does anyone know how I can fix this. I'm running ubuntu 13.10 and I have read and herd that this is a ubuntu bug that's not suppose to happen. Everything is configured in the /etc/fstab file as expected and boots perfectly. so what would I have to do to get my disk quotas to work properly? thanks all.

3 Replies

If I am remembering correctly you need to boot a custom kernel to have quota support. The pre-provided Linode kernels do not have support for quotas.

Add the following two lines to /etc/rc.local, right before 'exit 0' :

# /etc/rc.local

ln -s /dev/xvda /dev/root
/etc/init.d/quota restart

exit 0

That allowed me to start quotas in Webmin, and also have them persist after a reboot.

Bumping this very old thread - I had fixed the issue using the above and it was working, but I noticed recently that I had lost my quotas.

After some digging, I realised that the disks are now called sda (and sdb, sdc, etc). The xvda device no longer exists.

So I deleted the logical link to root and recreated it pointing to /dev/sda

Also edited the rc.local file so it will now create the link correctly and quotas should work on a reboot

[email protected]:/dev# cat /etc/rc.local
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
ln -s /dev/sda /dev/root
/etc/init.d/quota restart
exit 0

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct