Can't ssh in as root

Hi, after setting up my 14.04 linode by following most of this page

and setting a second user account, I ssh'd in as my second user account and continued setting things up.

I wanted to do 'reboot' and was told I need to be root to do that.

so I ssh'd in as root, but got 'invalid password' message.

So I reset my root password using this: … -passwords"> "Resetting the Root Password"

I ssh in again and I am still am told 'invalid password'

Any suggestions?


6 Replies

Can you sudo to root from your second account? If you can then your password is OK and the issue is your ssh config

Yes! I can do

sudo su root


I will try and figure out what's wrong with my ssh config, thanks.

Check "permitrootlogin" setting in sshd_config

Ubuntu 14.04 by default only allows root logins with ssh keys as sweh said check PermitRootLogin in /etc/ssh/sshd_config it will be set to without-password

Our image allows root login with password over SSH. But following that guide involves setting PermitRootLogin to "no":

> Set “Port” to “44444” and “PermitRootLogin” to “no”. Save the file and restart the SSH service:

Hey. I'm having the same troubles as Mazz, except for I have no second user. I've followed the … -passwords"> document as well.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct