trying to define a new CNAME

I am trying to define some CNAME alias to my domain using DNS Manager … I have tried

Hostname example.com

Aliases to www.example.com

and it fails with

• Record conflict - CNAMES must be unique

• Invalid hostname ''

have also tried the reverse

Hostname www.example.com

Aliases to example.com

which fails with

• Record conflict - CNAMES must be unique

What am I missing here ?

8 Replies

It is recommended against (and thus a restriction placed in our DNS Manager) that you can not create a CNAME record for your root domain. Even apart from conflicts, this wouldn't work.

Now as for the error you are receiving, it's because you already have an A record set for your root domain, and your www subdomain. These are both basic A records created when you make a default DNS zone.

So even if you were to remove the two A records, you still would be unable to create a CNAME for the root domain due to the above limitation I mentioned, but you should be able to create one for www.

However, if you are just trying to make sure your www is used properly, have both use an A record that goes to your IP as they did originally (or do now), and use your virtual host configurations to handle the rest. In Apache you can have your vhost setting pick up example.com as your ServerName, and www.example.com as your ServerAlias. If you wish to standardize the use of them, you can utilize rewrite rules.

OK so I have created my set of domain aliases using Type A records

instead of using CNAME which works fine for the scale of domains I deal with.

Might help the next person if the doc would emphasize this :

https://www.linode.com/docs/networking/ … troduction">https://www.linode.com/docs/networking/dns/dns-records-an-introduction

Every other hosting provider I have seen allows aliases setup using CNAME

which makes it easier when changing the IP ( just one Type A record change instead of every CNAME ).

All is well - thank you for your kind help

I have successfully created a google cname record for the purpose of redirecting my domain to their blog site. Everything looks good in the DNS zone file. However after 4 days, the cname change is not reflected anywhere on the internet at sites like leafdns.

Is there a bug with linode DNS? (idscannersDOTscanmyidDOTcom)

I'm not seeing a CNAME record here:

$ dig -t ANY idscanners.scanmyid.com

; <<>> DiG 9.7.3 <<>> -t ANY idscanners.scanmyid.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51951
;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 5, ADDITIONAL: 5

;; QUESTION SECTION:
;idscanners.scanmyid.com.       IN      ANY

;; ANSWER SECTION:
idscanners.scanmyid.com. 86399  IN      NS      ns3.linode.com.
idscanners.scanmyid.com. 86399  IN      NS      ns4.linode.com.
idscanners.scanmyid.com. 86399  IN      NS      ns1.linode.com.
idscanners.scanmyid.com. 86399  IN      NS      ns2.linode.com.
idscanners.scanmyid.com. 86399  IN      NS      ns5.linode.com.
idscanners.scanmyid.com. 86399  IN      SOA     ns1.linode.com. steve\.patco.gmail.com. 2017041483 14400 14400 1209600 86400

(other sections omitted)

Someone else in another topic was having DNS problems - maybe put in a support ticket?

You are right. Even though the zone file in cpanel shows the cname, no one else sees it.

````
$ dig idscanners.idscanners.scanmyid.com aaaa

; <<>> DiG 9.10.3-P4-Ubuntu <<>> idscanners.idscanners.scanmyid.com aaaa
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64576
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;idscanners.idscanners.scanmyid.com. IN AAAA

;; ANSWER SECTION:
idscanners.idscanners.scanmyid.com. 3600 IN CNAME ghs.google.com.
ghs.google.com. 520728 IN CNAME ghs.l.google.com.
ghs.l.google.com. 299 IN AAAA 2607:f8b0:400c:c0f::79

;; Query time: 162 msec
;; SERVER: ::1#53(::1)
;; WHEN: Sat Apr 22 21:49:34 UTC 2017
;; MSG SIZE rcvd: 136

````

There's a CNAME record with the name "idscanners" in the zone "idscanners.scanmyid.com".

There isn't – and, currently, can't be -- a CNAME record with the name "idscanners" in the zone "scanmyid.com".

You should delete the "idscanners.scanmyid.com" zone, create the CNAME record in the "scanmyid.com" zone, and copy over any other important records.

You need to change your DNS settings.

There is/has been a cname record in linode dns for idscanners.

Leafdns.com does not show a cname record in either idscannersdotscanmyiddotcom or scanmyiddotcom,

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct