Docker network problem with Linode

- Start with base Linode CentOS 7 - no other packages installed, no firewall rules altered, clean install.

yum update

yum install docker

chkconfig docker on

service docker start

docker run -i -t fedora /bin/bash

  • inside the Docker container:

[root@c9f79f5d018b /]# curl

curl: (56) Recv failure: Connection reset by peer


[root@c9f79f5d018b /]# ping -c2

PING ( 56(84) bytes of data.

64 bytes from ( icmp_seq=1 ttl=52 time=43.9 ms

64 bytes from ( icmp_seq=2 ttl=52 time=43.9 ms

Ping works, but no tcp connections. curl to other hosts results in same result. Can't run yum (times out).

Same process tried for Ubuntu 10.04 LTS and Debian 7 as base distros, same problem each time.

Linode support has been trying to help, but no answers so far. They've tried it themselves and it works fine for them. They have also migrated machine to a different host. Same result.

I'm out of ideas. Anyone?

9 Replies

Also, just tested CentOS 6.5. Same problem.

When you say "other hosts" have you tried non-Linode sites? I have run into odd disconnects myself when accessing Linode sites (e.g., this forum, the Linode guides). They seem to occur when multiple connections are initiated, leading me to think that some sort of DoS protection is being triggered at the load balancer (alternatively, it may have something to do with cache headers).

Anyway, make sure you try reaching web sites that you know aren't connected to Linode's load balancers.

I have tried many other sites, both ones under my control and general internet sites (,, Same result. Sites can be reached by the Linode machine, but not from within the containers. The container can resolve the DNS, but fails to connect via tcp. The problem first manifested itself trying to build a container running "yum":

[root@7961df4985e3 /]# yum update

Loaded plugins: fastestmirror

Could not retrieve mirrorlist … nfra=stock"> error was

12: Timeout on … nfra=stock"> (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')

Ah, OK. It's possible there's a firewall problem, but that seems unlikely given that ping's ICMP and DNS UDP packets get through. Sorry, I'm not familiar with Docker so don't have much to add.

Linode support has been able to reproduce the problem and are working to discover what the cause is. I will update this thread with what I hear. In the meantime, I'd be interested to know if anyone else has experienced this with new Linodes running Docker. Are there just certain hosts or regions this is happening in?


Can you please provide the ticket ID? I'd like to take a look at this ticket and hopefully shine some light on this issue.




After further investigation, we have determined that this is an issue with the physical server that the Linode was on. We have forwarded this to our administrators and our Hardware Team so that this issue can be resolved. We do not have an ETA for the time that it will take for us to resolve the issue, as the issue is present only on a specific server build.

This being said, this issue will not happen across all physical servers, but only specific ones. In the event someone else experiences this issue, they should reach out to us via ticket so that we can look into this issue for them.

We appreciate your patience and understanding.

Thank you,

Dave Russell Jr

Linode Support Specialist.


Just want to chime in from Docker Inc, that we too were experiencing this problem and in working with the Linode team have confirmed that their fix indeed resolves the issue.


Yup - you guys should be good to go.




Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct