Upgraded from Ubuntu 10 to 14 and wedged machine

Hi all

I don't know if I bricked my VM after upgrading Ubuntu server.

I can log in using the rescue option, but I'm not sure what logs to look at to troubleshoot.

Are there any pointers or documents to help out?



2 Replies

What did you run to upgrade it? What was the output? What happened next? What happens when you try to boot? What shows up on lish during a boot? Have you tried mounting the filesystem when booted into Rescue Mode? What does the filesystem look like?

thanks Akeri,

I ran do-release-upgrade from Lucid to LTS.

There was a problem with unauthenticated packages at first, and I allowed it to make it work.

When I try to boot, I'm no longer able to ssh in

I can boot up in rescue and mount FS, and retrieve my files. Otherwise, I don't know enough about linux recovery to see what's out of place.

My lish window looks like this:

NET: Registered protocol family 17

NET: Registered protocol family 15

bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you n

eed this.

Bridge firewalling registered

Ebtables v2.0 registered

8021q: 802.1Q VLAN Support v1.8

sctp: Hash tables configured (established 65536 bind 65536)

Key type dns_resolver registered

Key type ceph registered

libceph: loaded (mon/osd proto 15/24)

mce: Unable to init device /dev/mcelog (rc: -5)

Loading compiled-in X.509 certificates

registered taskstats version 1

Btrfs loaded

Key type encrypted registered

console [netcon0] enabled

netconsole: network logging started

hctosys: unable to open rtc device (rtc0)

md: Waiting for all devices to be available before autodetect

md: If you don't use raid, use raid=noautodetect

md: Autodetecting RAID arrays.

md: Scanned 0 and added 0 devices.

md: autorun …

md: … autorun DONE.

EXT3-fs: barriers not enabled

kjournald starting. Commit interval 5 seconds

EXT3-fs (xvda): mounted filesystem with writeback data mode

VFS: Mounted root (ext3 filesystem) readonly on device 202:0.

devtmpfs: mounted

Freeing unused kernel memory: 1496K (ffffffff82139000 - ffffffff822af000)

Write protecting the kernel read-only data: 16384k

Freeing unused kernel memory: 344K (ffff8800019aa000 - ffff880001a00000)

Freeing unused kernel memory: 1896K (ffff880001e26000 - ffff880002000000)

random: init urandom read with 92 bits of entropy available

random: nonblocking pool is initialized


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct