Postfix install from source on Linode


I installed Postfix 2.0.4 from sources. Everything went smoothly until I tried to run postfix, "postfix start"

It writes: Jul 24 04:24:45 maggie postfix/postfix-script: starting the Postfix mail system

But there's no master process running, when I tried run master process by hand it said: Jul 24 04:54:25 maggie postfix/master[313]: fatal: unable to set session and process group ID: Operation not permitted

Debian package of Postfix 1.1 seems to run ok.

2 Replies

sounds like a user/permissions problem. check your postfix/ configuration file. are you running chrooted? is the chroot setup properly?

run "postfix check" to have postfix try and find any permissions problems for you

No, last thing I did was "make install"

This is what I get to syslog after running postfix start, postfix stop.

Jul 26 16:23:51 maggie postfix/postfix-script: fatal: the Postfix mail system is not runningJul 26 16:24:40 maggie postfix/postfix-script: starting the Postfix mail system

I've done this install on two machines successfully, and those are working fine (those machines are also real boxes, not uml)

Could someone please try to install postfix 2.0.3 from sources?


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct