Cannot apt update after linode forced migration

Aloha, all.ug

So all has been running fine with my VPS for as long as I've had it. Until recently.

Linode sent me emails about a scheduled migration. I had no idea what it was for, or why it was necessary, but I assumed it wouldn't be a problem. I just ignored the emails, and let it go through. Now, today, when I want to install some more packages, I find out that the linode mirrors that come preinstalled (I didn't ask for those, but whatever) are not responding. Doing 'sudo apt update' hangs at '0% [Connecting to mirrors.linode.com]…'

Maybe it's a problem with the linode mirrors? So I use the default for /etc/apt/sources.list with https://repogen.simplylinux.ch/. That also doesn't work. So now I try a simple test: lynx http://google.com … Nothing. That also hangs. So it's the VPS I guess. Somehow the network isn't configured properly. Now, I have played with the firewall (ufw) to allow through (in and out) some apps, but that was all working hunky dory before the migration. And even if I disable ufw, nothing changes. So I'm at a loss.

Oh, and weirdly… If I do 'lynx http://bing.com' it works as expected.

Any ideas on how I can debug this?

Cheers

2 Replies

Hello,

I'm sorry you're running into this problem. When you curl -v mirrors.linode.com, what is the response? Is it connecting over IPv6? Can you try to run "apt-get -o Acquire::ForceIPv4=true update"?

I hope this helps!

Regards,

Stephen Crane…

Linode Customer Support

I have the same problem after my node migrated from Tokyo 1 to Tokyo 2 data center.

[email protected]:~# curl -v mirrors.linode.com

  • Rebuilt URL to: mirrors.linode.com/
  • Hostname was NOT found in DNS cache
  • Trying 2400:8902:1::8ba2:5ef6…
  • Trying 139.162.94.246…
  • connect to 2400:8902:1::8ba2:5ef6 port 80 failed: Connection timed out
  • connect to 139.162.94.246 port 80 failed: Connection timed out
  • Failed to connect to mirrors.linode.com port 80: Connection timed out
  • Closing connection 0
    curl: (7) Failed to connect to mirrors.linode.com port 80: Connection timed out

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct