Connection randomly timing out

Hey All,

I am running postfix and courier-imap on my server for mail.

I am using Thunderbird to read my mail. For some reason, at random but frequent times, Thunderbird reports that the connection to the server timed out, and I am not sure why.

I did a tail -f on the mail and syslogs, but no entries are being noted about a timeout. I can't figure out why the mail is timing out, because I also use Thunderbird to check another IMAP account (work account) and that one does not time out.

I'm not sure where to look, any ideas/suggestions?



6 Replies

It could be that the load spikes mentioned on the Performance and Tuning forum. Could be causing the connection to your server to be timed out.

Other than that it could just be random network problems.


My node isn't having any load spike issues, so I dunno. It's wierd that that account times out, but my other account does not.

If anybody else has any suggestions, please let me know :)

Is it a ginormous mail folder that's causing reads to take a long time and timeout for that user?


I'm only using 1 email account, and using Maildir's, but the size of the folder is only 3.5MB, so don't think that's it.

root@girls [/home/webmaster]# du -sh Maildir/
3.5M    Maildir/

It might be the reverse dns lookups or rfc1413 (ident) callbacks which for some connections it just stalls. I've always had stall/timeout probs because of those two and I usually turn off reverse dns lookups and ident (rfc1413) callbacks.

I don't know exactly how to do it with postfix (I have experience with exim and courier as MTAs) but maybe someone else can, or even yourself ;)

Much luck

Update: I may have narrowed down the issue. I've been downloading a lot of stuff lately. I shut down the downloads for an hour, and the mail hasn't timed out in that time, so it appears to be related to the downloads using a lot of the pipe.

Now the question/issue is why does my other IMAP account (at work) not time out, but my webserver IMAP account does. Any ideas on that? Is there some type of timeout setting on the server, like in postfix or courier-imap that maybe I need to increase?




Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct