Longview not recieving any data.

I've installed longview using the curl link and it's been sitting idle for a while without any data.. It's running on the linode:

[email protected]:~# sudo service longview status
● longview.service - LSB: Longview Monitoring Agent
Loaded: loaded (/etc/init.d/longview; generated; vendor preset: enabled)
Active: active (exited) since Wed 2018-07-18 19:07:13 NZST; 2 weeks 0 days ago
Docs: man:systemd-sysv-generator(8)
Process: 4866 ExecStart=/etc/init.d/longview start (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 4915)
CGroup: /system.slice/longview.service

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

When I disable UFW - I still don't get any data. I'm on Deb9.

Suggestions?

1 Reply

Have you checked that your system is using the correct API key? To view the key on your system run:

sudo cat /etc/linode/longview.key

Then, compare that with the key located on the Manager:

Longview > Click your Client > Click the Settings tab

If the API keys do not match, grab the API key from the Manager and run the following on your Linode:

sudo echo "$API_KEY" > /etc/linode/longview.key

Our Longview Guide has some troubleshooting steps you might find useful. Also, feel free to open a ticket and our Support team will take a look. If you do open a ticket, please include output from these commands:

sudo /etc/init.d/longview stop
sudo /etc/init.d/longview debug
sudo tail -30 /var/log/linode/longview.log
sudo cat /etc/linode/longview.key

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct