What's listening on port 16385?

I'm running Ubuntu 16.04.5 LTS (GNU/Linux 4.17.8-x8664-linode110 x8664) on a Linode. Yesterday I applied some package updates ("apt-get upgrade") and noticed that something was now listening on port 16385. It wasn't before the package updates.

# netstat -an | grep 16385
tcp        0      0 *               LISTEN

I rebooted, and something is still listening on this port.

I tried using "ss" to determine the owner process ID, but none was shown.

# ss -lptn 'sport = :16385'
State      Recv-Q Send-Q                                   Local Address:Port                                                  Peer Address:Port              
LISTEN     0      64  

I've tried a Google search, and can't find anything that uses 16385 as a well known port.

Any ideas on what's using this port or how to find that out?


3 Replies

Forgot to mention: we're seeing this on multiple Linodes.

This was due to a kernel configuration that was enabled in our 4.17.8 kernel, which enabled Reliable Data Streams.


Due to the confusion it has caused, it is now disabled in more recent kernel releases. The designated "Latest Kernel" will be updated to one of these newer kernels in the next few days, so a reboot at that time will be all it takes to make this go away.

It is safe to leave enabled for now, but if you want to use a kernel with this disabled, you can switch to our 4.17.12 kernel in your Linode's Configuration Profile. Please note that you will have to switch back to "Latest" if you want it to be updated automatically on reboots over time.



Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct