Can't connect to SSH

I'm not able to connect to my Linode via SSH.

1 Reply

If you cannot connect via SSH, you can use our out-of-band LISH console to connect instead. From there, you can run the command:

sudo netstat -plunt
cat /etc/ssh/sshd_config | egrep 'PasswordAuth|PermitRoot|Port'

The first command will let you verify that your SSH server is running and listening to the correct port, while the second will let you verify your current port/authentication settings.

You can also test with Nmap and MTR from a remote machine:

nmap -p <port> <ip.address>
mtr -T -p <port> -rwbzc 100 <ip.address>

Just substitute the port number your SSH service is running on for <port> and the IP address or hostname of your Linode for <ip.address>

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct