How do I configure my private IP in Ubuntu 18.04?

Linode Staff

I have just added a Private/LAN ip address to my linode. After login and executing ifconfig it does not showing the private IP address in my linode. I'm running Ubuntu 18.04 if it makes a difference.

How do I get it configured?

3 Replies

Linode Staff

If you are using Network Helper, your private IP should be accessible as soon as you reboot your Linode. Our guide on our Network Helper will help you enable it from the Configuration Profile of the Linode.

After the reboot, run

ip a

You should see your private and public ip address.

If you'd prefer not to use Network Helper, or want to configure it statically, you'll need to add the private ip the following file:

/etc/systemd/network/05-eth0.network

Our guide on Static Networking goes into this in greater detail.

Network Helper seems to be broken for Private IPs in Ubuntu 18.o4, I have gone through the above Network Helper tutorial to enable it. But my box does not receive a new private ip interface when I run ip a. Oddly enough I am able to communicate with it on the new private ip address.

@keener2u --

You write:

But my box does not receive a new private ip interface when I run ip a.

The emphasis is mine…

ip a is short for ip address show. You need to give ip a more info for it do something else. Consult man ip-address

-- sw

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct