Does Linode block XML-RPC?

Linode Staff

I got my Wordpress blog up and running again after migrating from a different VPS provider. When accessing the blog with the Wordpress app however, I get an error stating "required XML-RPC methods are missing on the server" even though I can see that the "xmlrpc.php" file exists in the /var/www/html/ directory.

Searching online I've come across some reports that providers might block access to this file for security reasons. Is that the case for Linode, and if so, is there a way to work around this?

2 Replies

As XML-RPC is an API used by mobile applications to access Wordpress, that error message does indicate that it’s blocked or disabled. Linode does not block this at a network level, but if you deployed Wordpress using the One-Click App, then your Apache configuration is blocking xmlrpc.php by default.

<files xmlrpc.php>

order allow,deny

deny from all


To allow XML-RPC, remove this block from your virtual hosts configuration and reload Apache.

sudo systemctl reload apache2

Otherwise there may be a plugin or block.conf file that is disabling/blocking XML-RPC.

I've had a similar issue, and it turned out I was missing the php-xml package. So I did this (on Ubuntu):

sudo apt-get install php-xml

And then:

sudo service apache2 restart

And now it works!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct