How do I clear up ERR_TOO_MANY_REDIRECTS error on my new linode-hosted domain?

I have hosted two domains on my linode since 2005.

Recently I registered a new domain name with GoDaddy: lerner-minsky.org. On my linode, I created a directory tree and files for this new domain.

#

$ find /var/www/html/lerner-minsky.org/ -type f
/var/www/html/lerner-minsky.org/public_html/index.html
/var/www/html/lerner-minsky.org/logs/access.log
/var/www/html/lerner-minsky.org/logs/error.log

#

When I login to https://cloud.linode.com/dashboard and examine the pages for each of my three domains, they are populated as expected, i.e., they differ only in the domain name. I also created an index.html page for this new domain. When I copy that page to my desktop and open it as a local .html file, it displays as expected.

However, when I enter the URL for this domain in a browser, I am not connected to new domain's home page.

#

http://lerner-minsky.org/

#

In Firefox:

#

The page isn’t redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
This problem can sometimes be caused by disabling or refusing to accept cookies.

#

In Chrome:

#

This page isn’t working lerner-minsky.org redirected you too many times.
Try clearing your cookies.
ERR_TOO_MANY_REDIRECTS

#

I doubt that this problem has anything to do with cookies. The single page active in this domain makes no reference to cookies. Most of the pages I find through Internet search engines deal with ERR_TOO_MANY_REDIRECTS in the context of more complex applications such as WordPress. I don't know what questions I should be asking GoDaddy.

Can anyone make suggestions?

Thank you very much.
Jim Keenan

7 Replies

Hey there,

We believe this may have to do with the following command options:

$ find /var/www/html/lerner-minsky.org/ -type f

According to man find the -follow option has a similar effect to -L, though it takes effect at the point where it appears. If -L is not used but -follow (or -f) is, any symbolic links appearing after -follow on the command line will be dereferenced, and those before it will not.

This dereferencing may be contributing to this issue. We recommend backing up and removing /var/www/html/lerner-minsky.org/. Then you can use the following to recreate the file with the appropriate links:

find /var/www/html/lerner-minsky.org/ -type L

You can use this third party tool to check the status of your redirects for the domain in question to help test this troubleshooting (or gain insight into the issue for other customers).

We hope that helps. Feel free to let us know how this worked for you.

Sincerely,
Tara T
Linode Support Team

@Ttaylor, thank you for taking a look at this problem.

Unfortunately, that got me nowhere. For one thing, your suggestion with respect to find is inaccurate. I can call this:

$ find -L /var/www/html/lerner-minsky.org/ 
/var/www/html/lerner-minsky.org/
/var/www/html/lerner-minsky.org/public_html
/var/www/html/lerner-minsky.org/public_html/index.html
/var/www/html/lerner-minsky.org/logs
/var/www/html/lerner-minsky.org/logs/access.log
/var/www/html/lerner-minsky.org/logs/error.log

And I can call this:

$ find /var/www/html/lerner-minsky.org/ -type l
# No results, as none of the files in that tree are symlinks.

But upper-case L is not a valid argument for the type switch.

$ find /var/www/html/lerner-minsky.org/ -type L
find: Unknown argument to -type: L

With respect to the third-party tool, all it told me was what I already knew:

Request URL,# Redirects,Status Code,URL,Error Message
http://lerner-minsky.org,,,,Exceeded maximum number of redirects.

(contents of downloaded CSV file)

Other suggestions?

The problem most likely is due to server configuration (and nothing to do with find) can you post the files?

@kmansoft Which files, specifically?

Thank you very much.

Depends on your web server nginx or apache. You'll want to look under /etc/ apache or /etc/nginx for sites-enabled

@kmansoft, thank you for that suggestion -- but it appears that more still needs to be done.

I created the following file in /etc/apache2:

$ cat ./sites-available/lerner-minsky.org.conf
<VirtualHost *:80>
     ServerAdmin [email protected]
     ServerName lerner-minsky.org
     ServerAlias www.lerner-minsky.org

     DirectoryIndex index.html
     DocumentRoot /var/www/html/lerner-minsky.org/public_html/

     LogLevel warn
     ErrorLog /var/www/html/lerner-minsky.org/logs/error.log
     CustomLog /var/www/html/lerner-minsky.org/logs/access.log combined

     Options ExecCGI
     AddHandler cgi-script .pl

</VirtualHost>

I created this file by doing a simple copy, search and replace on one of my sites-available/*.conf files that has been working for 14 years.

I then symlinked to this file from /etc/apache2/sites-enabled. I then restarted Apache2. I confirmed that my two existing sites would re-load. But when it came to lerner-minsky.org, I'm still getting the same error, e.g., in Chromium ERR_TOO_MANY_REDIRECTS.

I should add: On the basis of the size of the log files, this domain is still not being reached.

$ ls -l /var/www/html/lerner-minsky.org/logs 
total 0
-rw-r--r-- 1 root root 0 Jun 12 14:45 access.log
-rw-r--r-- 1 root root 0 Jun 12 14:45 error.log

So I think this is a step in the right direction but further problems remain.

Thank you very much.
Jim Keenan

Hmm don't see anything wrong there. Do you have any .htaccess files under the domain's content directory? Or maybe more config files elsewhere?

The error message means that:

When the browser goes to fetch http://yourdomain/ the server returns a redirect (that page is really over there) - and if the "over there" is the same URL then that's an infinite redirect.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct