Weblish is stuck and showing this error message: Kernel panic - not syncing: Attempted to kill init!

Linode Staff

I'm getting boot errors in the Weblish console, and it appears to be frozen.
The most recent error is:

[ 2.650104] Run /bin/init as init process
[ 2.652471] Run /bin/sh as init process
/bin/sh: 0: can't access tty; job control turned off

And here is one from the previous console log:

Kernel panic - not syncing: Attempted to kill init!

1 Reply

It looks like the initial kernel panic is the issue here. This can happen for a variety of reasons, but in this case, it might be due to some sort of file system corruption. The kernel was unable to move past the init process, and that's why it appears stuck.

I found a really good explanation of what kernel panic is from linuxquestions.org:

Kernel Panic (not syncing): attempted to kill init!

To troubleshoot this, I would recommend booting your Linode into Rescue Mode and running a file system check. This will examine your file system for errors and attempt to repair them if possible.

You will also want to make sure that you have enough disk space allocated to your primary disk in your advanced configuration settings. This will ensure that there is enough buffer space on your hard drive for the necessary processes to occur.

Hopefully this points you in the right direction!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct