systemd-journald can't write or rotate entries

My server's response time is slow, and the below information was printed to my terminal. What does this mean and how do I fix it?

[3157306.520414] systemd-journald[611]: Failed to write entry (20 items, 476 bytes), ignoring: Argument list too long
[3157306.524454] systemd-journald[611]: Failed to rotate

1 Reply

I'm sorry to hear that you are having this problem. Accord to the systemd-journald.service man page, /run/log/journal/ files should not persist after a reboot. A reboot may temporarily fix any issues you are experiencing.

The journal service stores log data either persistently below /var/log/journal or in a volatile way below /run/log/journal/ (in the latter case it is lost at reboot).

If you don't want to reboot, there are a few steps you can take to gather more information on the issue. You can start by checking the Linode's disk usage using df -h. You can also use the below commands to get a better understanding.

  • To find more journal log information:

ls -a /var/log | grep journal

  • To check for corrupted files that you can manually remove:

sudo journalctl --verify

  • To see how much disk space is allocated to journal logs:

sudo journalctl --disk-usage

From there, you can try manually removing archived log files. As a long-term option, you can use journald.conf to control the size of your logs' disk usage.

I hope this information has been helpful! Please, feel free to reply to this post with any additional questions, and a member of the Community may be able to help you.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct