How do I add an A record to point to my root domain?

I can point to my linode. But won't work for some reason.

I've done this before (I think) by adding a "@" as the hostname when adding the A record. But when I try adding this in the Linode DNS manager, it says the "@" is an invalid character.

The weird thing is, the IP address that the root domain directs to is totally different to any of the addresses that are in the A/AAAA records. I have waited over 24 hours for propagation. Am I missing something?

4 Replies

Have you tried leaving it blank? I think that should do the trick for you since leaving it blank is the equivalent of using '@'.

I'll try it out, thanks a lot for the quick response. Edit: It worked, thanks again

Bumped into the same issue… Maybe it would be good to add to the docs?


@frantic0 - I agree. I've asked our Docs team to add a line to our DNS Manager guide stating to leave the hostname blank in place of @. Thanks for your feedback!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct