Volume not resizing

I've resized my volume up from 10GiB to 85GiB this morning and that worked fine; I followed the e2fsk and resize2fs steps and that worked fine.

An hour later I resized it again up from 85GiB to 90GiB but that second resize is not taking effect according to e2fsck and resize2fs tools. I've followed all the instructions clearly and unmounted and repeated the same procedure multiple times but the tools state the volume size is still 85GiB (22282240 4k blocks).

Is this metadata cached? Do I need to wait some amount of time for the resize to take effect? The first resize did not seem to require any delay and took effect nearly immediately after I got the notification in my dashboard that the volume was resized.

[email protected]:/home# e2fsck -f /dev/disk/by-id/scsi-0Linode_Volume_srv
e2fsck 1.44.1 (24-Mar-2018)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/disk/by-id/scsi-0Linode_Volume_srv: 91552/5570560 files (1.0% non-contiguous), 20461220/22282240 blocks
[email protected]:/home# resize2fs /dev/disk/by-id/scsi-0Linode_Volume_srv
resize2fs 1.44.1 (24-Mar-2018)
The filesystem is already 22282240 (4k) blocks long.  Nothing to do!

4 Replies

It's a full day later and the e2fsck tool still reports the exact same volume size as before the resize.

Any updates to this? I am having the same issue.

As I cannot see the process you took on the resize, I'm going to speak in general terms of how the resize works in order to cover as many bases as possible in the event others find this post and are looking for help with the same issue.

The first thing to keep in mind about a Volume resize is that the actual resize occurs during a reboot of your Linode so make sure you do that once you've resized the Linode through the Cloud Manager.

Once you reboot, you'll need to run the e2fsck and resize2fs to complete the resize. Before running those, you'll want to make sure the Volume is unmounted. It can be mounted again once those commands are run. Here is the rundown f thw commands from the guide:

umount /dev/disk/by-id/scsi-0Linode_Volume_$volume

e2fsck -f /dev/disk/by-id/scsi-0Linode_Volume_$volume

resize2fs /dev/disk/by-id/scsi-0Linode_Volume_$volume

mount /dev/disk/by-id/scsi-0Linode_Volume_$volume/mnt/$volume

Make sure to replace the $volume with your Volume's label in each of those steps.

Once you've done this, you can run the following command to make sure that the Volume has resized correctly and is displaying the correct size:

df -h /dev/disk/by-id/scsi-0Linode_Volume_$volume

Doing the steps in this order should give you a successful resize. Let us know if you're still running into issues and we're happy to help troubleshoot further.

Hi--

It does appear that this can be resolved by rebooting the instance and then doing the commands Linode suggests. If you do not reboot, it does not appear to resize.

Eric

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct