Kubernetes Service type LoadBalancer does not get external IP

I created a LKE Kubernetes cluster as part of the beta program, created LoadBalancer-type Service according to https://www.linode.com/docs/kubernetes/deploy-nodebalancers-with-linode-ccm/ and ran into a problem that the corresponding "NodeBalancer" gets created and receives traffic, but my Serivce resource does not receive it's public IP address, in kubectl get service it snows EXTERNAL-IP as <pending>. Is this a bug?

I wanted to troubleshoot the problem, but I don't see the Linode CCM running as a pod in the cluster (as mentioned in the above mentioned documentation). So I'm wondering where it is running, as the NodeBalancers are being created according to my Service resources.

1 Reply

Yesterday I tried to delete the service with still pending external IP, recreated, and it worked now, the service received the external IP correctly ¯\_(ツ)_/¯


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct