Unable to clone Linode to the same sized plan.

Linode Staff

I just finished setting up a 2GB Linode and would like to clone it. However, when I go through the cloning process and select the 2GB Plan, I get this error message:

"The source Linode has allocated more disk than the new type allows. Delete/resize disks smaller or choose a larger type."

I don't want to choose a larger plan. What should I do?

1 Reply

Hey, I ran into this issue before.

If you delete your swap disk then you should be able to successfully clone your Linode. Here are the steps that worked for me and other customers.

  • Power down your Linode
  • Navigate to the Linode's Disks/Config page (previously named Advanced)
  • Remove the Swap Image Disk
  • Create the Clone
  • After the cloning process completes, create a new swap disk for both Linodes.

If you follow this guide to create the new swap disk, be sure to choose swap instead of ext for the filesystem. Also, the 512 MB size should fit nicely with the 2GB Linode plan. Hope this helps!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct