Unable to generate certificates using certbot

I'm following the example shown in https://certbot-dns-linode.readthedocs.io/en/stable/

certbot certonly \
  --dns-linode \
  --dns-linode-credentials ~/.secrets/certbot/linode.ini \
  -d example.com

I get the following error

The requested dns-linode plugin does not appear to be installed

How do I install the dns-linode plugin?

4 Replies

What OS are you running and what version of Certbot? Also how did you install it, from the repositories (OS or Certbot’s?) or certbot-auto?

I tried about a year ago and the Linode plugin wasn’t in the standard repositories yet.

You may also have some success using acme.sh instead.

I'm running Debian 10, I got certbot(0.31.0) using apt install certbot. I fixed my original issue, seems like I had to install it via apt-get install python3-certbot-dns-linode.

I can now successfully generate a certificate for myurl.com, but when I run the command with www.myurl.com it gives this error:

Unexpected error determining zone identifier for www.myurl.com: Linode api error: [{'ERRORMESSAGE': 'Authentication failed', 'ERRORCODE': 4}]

My linode.ini file, I generated tokens via https://cloud.linode.com/profile/tokens

dns_linode_key = 0123456789abcdefghijklmnopqrstuvwxyz
dns_linode_version = 4

Any ideas why it would be failing with www and succeeding without?

Thanks!

You don't have an A/AAAA record in DNS for www.myurl.com?

-- sw

Linode Staff

To piggyback on what @stevewi asked, you'll want to make sure you have all the correct A records set up. Here's a guide that shows you how they should correctly be configured:

Add DNS Records

Make sure you have an A record set for www as well.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct