php7.2 GD error

I am getting error in loading php-gd

PHP Warning: PHP Startup: Unable to load dynamic library 'gd' (tried: /opt/remi/php72/root/usr/lib64/php/modules/gd (/opt/remi/php72/root/usr/lib64/php/modules/gd: cannot open shared object file: No such file or directory), /opt/remi/php72/root/usr/lib64/php/modules/gd.so (/lib64/libraqm.so.0: undefined symbol: hb_ft_font_set_load_flags)) in Unknown on line 0
Extension 'gd' not present.

can you please guide what to do?

I am using PHP7.2 and centos 7.5

1 Reply

Linode Staff

Hey there -

I found a potential fix for you on Stack Overflow. It's an older post, but the fix still should apply.

Basically, what it's saying is that there's an extension line in one of your PHP configuration files that's trying to load that extension, but either the path doesn't exist or there's a permissions error.

Here's a link to the post that will give you more detail:

PHP Warning: PHP Startup: Unable to load dynamic library

If you have to install (or re-install) php-gd, this should help you out:

CentOS: Enabling GD Support in PHP Installation

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct