FileZilla Permissions Errors (Connection Refused)

Linode Staff


I am getting "connection refused" when using SFTP to connect to my Linode via FileZilla. I have set the proper public and private keys and am able to access my Linode using SSH directly. Why am I unable to connect with FileZilla?

1 Reply

Hi there,

The best way to check for the root cause of these errors is to connect to your Linode via SSH and then run:

tail -f auth.log

Following that, attempt a connection via FileZilla. You will see information regarding why your connections are being refused. For example:

Directory "/run/systemd/sessions" already exists, but has mode 0777 that is too permissive (0755 was requested), refusing.

This appears to be a security setting blocking users from connection who have permissions that are too lenient. To fix this, from your limited user on your Linode run:

chmod 755 <directory>

You will need to run this for each directory that is prompting the permissions error. From here you should be all set!

Aaron H.
Linode Customer Support


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct