Object Storage on nextcloud - can't save config

I am trying to add Linode Object Store to my nextcloud instance running on a linode ubuntu 20.04 server (min spec).

So I followed the guide here

It seems all very straight forward but I when I get to step 8 and click on the check icon to save my settings it effectively crashes each time (activity indicator on the left just keeps spinning). The folder is created in my file space but that's it, the folder is empty and not connected to my object store bucket (the bucket is not created on linode)

What's more, when I close the tab or browser and reconnect or login, then go back to settings in nextcloud and edit the 'external storage' app it is in the same state (i.e. looking like it is in mid-save) BUT I now have 2 or 3 duplicate entries doing the same thing. The number of 'duplicate entries' keeps rising each time I return to this configuration screen until eventually the whole instance freezes and I need to restart apapche2.

What I am doing wrong? Is there another port (other than 443) that needs to be open (I have ufw running on the box with just specific required ports open).

6 Replies

I set up the nextcloud docker container with object storage as the primary storage and it worked ok. That's a bit different to how you're setting it up.

To check for blocked traffic by ufw you can look at the output of sudo dmesg

Also have a look at the logs from nextcloud/php/apache.

Hello there,

I went through the exact same guide the other day so I thought I'd jump in and share some of my thoughts and experiences

To start, is your Nextcloud Linode a new deployment or one that you've already been using? If it's a new deployment, or one that isn't mission critical, it might be easier to delete it and start fresh. We recently launched a Nextcloud OCA so redeployment should be relatively quick.

Getting back to the issue at hand I can confirm that port 443 is the only one needed for the External Storage App to work. I'm not exactly sure what to make of the endless duplicate entires but have you tried rebooting the Linode and going back into Nextcloud? If not I would suggest giving that a shot. Rebooting might stop whatever is causing those entires to replicate themselves.

You might have done this already but I recommend double checking that your OBJ Keys were entered correctly. When I was going through this I left out a few characters and Nextcloud was unable to access my bucket as a result. I ended up creating another set of OBJ Keys specifically for this project. Not required, but it does give you the flexibility to revoke the keys if needed, without disturbing any other devices.

To mirror what crashbunny said I also suggest having a look at those various logs. If this issue is causing Apache to lock up/crash the Apache error log might shed some light on what is causing this. Feel free to include any log output in your next post.

Many thanks for the replies, the apache2 log shows no errors at all and there is nothing in the php logs either. I don't know where to look for nextcloud specific logs (nothing in var/log)

I have tired rebooting a number of times with no change and I have double checked the obj keys, they are correct. The instance of nextcloud was 'hand built' so I may try this with the OCA and see if that works.

I took a look at my own Linode and did not see any Nextcloud specific logs so there might not be any. Since Nextcloud uses Apache and MySQL it's likely storing log output in one of those directories, depending on the issue at hand.

/var/log/apache2/
/var/log/mysql/

Our Nextcloud OCA makes setup a breeze but it does take away so the fun that comes with doing it by hand. If you'd like to give it another go, the video I've linked below does a pretty detailed walkthrough of installing Nextcloud to a Linode.

- https://www.youtube.com/watch?v=EbD1hFzJtls

We also just uploaded a guide for using a Linode OBJ Bucket as the primary storage for Nextcloud. I've included the link below for anyone that is interested.

https://www.linode.com/community/questions/20323/using-object-storage-as-the-primary-storage-for-nextcloud

Thanks for all the support.

I have just given it one more go on my setup, this time I selected a different region (I am in UK so I have been selecting eu-central-1). This time I tried with us-east-1 and it instantly worked !!

I have done this like 3 or 4 times so I am sure I entered the information correctly on previous attempts

Anyhow, I now have it configured and working, albeit with my data in the US :)

EDIT: After running a whole series of tests today, I can confirm that I can configure this to work with us-east-1 region but NOT eu-central-1 or ap-south-1. us-east-1 works every time, the other regions fail to create an object store and send the nextcloud external storage app into a bit of a tailspin

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct