Gentoo default profile broken?


I'm setting up a gentoo linode and the first thing I did once logging in was an emerge –sync. I was greeted with the following error:
> Updating Portage cache: 90%!!! Cannot resolve a virtual package name to an ebuild.

!!! This is a bug, please report it. (virtual/ghostscript-0)

So the make.profile symlink is pointing to 2005.0 which I'm pretty sure is deprecated. I switched to /usr/portage/profiles/obsolete/x86 for the make.profile and tried to update portage which bombed at ncurses..

Didn't see anything on the wiki about this..

So am I doing something really really dumb or is this profile too old?

6 Replies

use /usr/portage/profiles/default-linux/x86

I think :)

Steps I followed:

1) Create disk image with Gentoo 2005.0 provided by Linode.

2) Boot this obsolete system

3) Tune some things like:

rc-update -d keymaps boot

rc-update -d consolefont boot

echo HOSTNAME="myhost" > /etc/conf.d/hostname

In make.conf, ensure a properly USE with thinks like -X -gtk -gtk2 etc…

4) Update portage tree: #emerge --sync (fails as your linode, no problem)

5) Upgrade portage: # emerge -u portage

6) rm /etc/make.profile

7) ln -s /usr/portage/profiles/default-linux/x86/2006.1

8) Sync again: emerge --sync

If you want a perfectly upgraded system…

9) #emerge gcc (take a long long time…)

Then, select your new compiler gcc-4.1.1 as your default compiler if you want it, with gcc-config (depracated but, eselect compiler isn't installed yet ;-) ).

Finally, rebuild all the packages with "emerge -e world".

At this point, you're running a Gentoo 2006.1.

Install everything, try kernels 2.6 etc… Enjoy!

I started on building a gentoo system yesterday, and this is pretty close to what I did. (or rather, am doing, takes a while…)

The emerge -u portage is not working for me so I went ahead and downloaded the most recent portage and then did emerge portage and everything "appears" to be working. I'll post a reply if this doesn't work. Thanks for the advice!

Update - Starting over….

I don't know what I did honestly. I was reading ALOT of stuff on's forums and I did attempt to try emerge --onetry --nodep portage. This appears to have worked and I now emerging gcc. Thanks for the info.

>>> Updating Portage cache: 90%!!! Cannot resolve a virtual package name to an ebuild.

!!! This is a bug, please report it. (virtual/ghostscript-0)

so I tried to emerge portage and I get this

!!! ARCH is not set… Are you missing the /etc/make.profile symlink?

!!! Is the symlink correct? Is your portage tree complete?

Im not sure how to fix this

I get the same if I try emerge -u portage

ln -s /usr/portage/profiles/default-linux/x86/2006.1 /etc/make.profile

seems to have gotten me passed that problem…


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct