Help to fix php...

Server running Virtualmin…
After upgrading my server to Ubuntu 18.04 LTS, which includes php7.2, None of my php pages will display in virtual domains. They just want to download. Php works & phpinfo does display from /var/www/html…(

I’ve spent quite a while searching, checking settings, etc..
Any suggestions or pointers to a reference site would be appreciated.


2 Replies

I started to look into this and came across this post on the Virtualmin support forum that details some steps taken by a user who experienced similar issues after upgrading to Ubuntu 18.04 while running PHP 7.2. If that link is not helpful, you'll want to start troubleshooting by checking the logs directory in the virtual servers home directory (ie, "/home/example/logs"). Another troubleshooting step would be to check your Linodes IP address (ie, # ip addr sh) against the one Apache is expecting requests to come in on by reviewing the VirtualHost section of your Apache config:

grep -i '<virtualhost' /etc/apache2/sites-enabled/*.conf

I know you mentioned doing some research on your end and checking some configuration settings as well, feel free to share more details here on those if the above does not point you in the right direction.

@cmcfarland --

The solution presented in the post will only be helpful if you're using the Apache PHP module libapache2-mod-php7.2.

If you're using php72-fpm, there is no /etc/apache2/mods-{available,enabled}/php7.2.conf file. You need to look at /etc/apache2/conf-{available,enabled}/php7.2-fpm.conf…which doesn't have any of the stuff mentioned in the post in it. One reason (of many) why using php72-fpm is preferable, IMHO.

-- sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct