✓ Solved

NodeBalancer keeps resetting proxy protocol from "v1" to "None"

I have a kubernetes cluster with a NodeBalancer and nginx ingress controller. I would like to know the IP adresses of the requests, so I have configured nginx with proxy protocol enabled and I set proxy protocol to "v1" in the configuration tab on the NodeBalancer.

At seemingly random times, the proxy protocol resets itself to the "None" setting. How do I avoid this?

2 Replies

✓ Best Answer

Hi there,

What is happening here is that you are attempting to manage the configuration of the NodeBalancer from the Cloud Manager. For non-LKE NodeBalancers this would totally be the go to spot. With LKE NodeBalancers however it is important to note that changes made via the Cloud Manager do not persist.

This is because the Control Panel for your cluster is not aware of changes made in Cloud Manager. During the normal life cycles of your cluster, the Control Panel may determine a discrepancy between the expected and actual settings of the NodeBalancer. It is at these seemingly random points that the NodeBalancer settings are then reverted to the default settings - which for proxy-protocol is None.

To make configuration changes to your LKE NodeBalancers that persist you'll want to take advantage of Annotations. We have a guide that goes into more detail regarding LKE specific NodeBalancer annotations, I'll link it below:

You may also want to review the steps provided in the following post:

I hope this information is helpful! :)


Thanks for your clear and comprehensive answer BD!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct