✓ Solved

the valheim script breaks from marketplace

Warning! Missing dependencies: libc6-dev libsdl2-2.0-0:i386

Warning! de4dpandas does not have sudo access. Manually install dependencies.
sudo dpkg --add-architecture i386; sudo apt update; sudo apt install libc6-dev 6

Failure! Missing dependencies required to run SteamCMD.

No gameserver Login Token Needed
no crontab for root
job for vhserver.service failed because the control process exited with error c.
See "systemctl status vhserver.service" and "journalctl -xe" for details.
Created symlink /etc/systemd/system/multi-user.target.wants/vhserver.service ->.
Running initial updates - This will take a while…
Installation complete!

i then run the systemctl status vhserver.service and get

(red light) vhserver.service - vhserver
Loaded: loaded (/etc/systemd/system/vhserver.service; enabled/ vendor preset:
Active: failed (Result: exit-code) since Fri 2021-12-10 05:56:33 UTC; 8min ag

8 Replies

✓ Best Answer

i got it had to manually install from steamcmd to the file path that the executable was missing from then used ./vhserver start to run the server. i think the reason this broke was just from the sources not including the steamcmd package or dependencies.

i have also ran the sudo dpkg --add-architecture i386; sudo apt update; sudo apt install libc6-dev 6
in order and it installed libc6-dev

but not when having the 6 behind it idk why that 6 is there because the space makes it look for a package called "6"

is there anyway to try to restart vhserver now that i have the dependencies or do yall think im missing more.

i then rebooted the linode hoping it would restart it

vhserver.service - vhserver
Loaded: loaded (/etc/systemd/system/vhserver.service; enabled; vendor preset:
Active: failed (Result: exit-code) since Fri 2021-12-10 06:21:45 UTC; 44s ago
Process: 467 ExecStart=/bin/bash /home/de4dpandas/vhserver start (code=exited,

i then did ./vhserver start
and get the output

[ FAIL ] Starting vhserver: executable was not found

  • /home/de4dpandas/serverfiles/valheim_server.x86_64

i dont know much about linux or servers or scripts but my guess is since when i try to install steamcmd the package is not found that it must have broke this script at this point and the folder created is missing the valheim executable from the above directory. so how should i go about this the easiest way i tried to make 3 valheim linodes this happens everytime. do i wget all the files i need? this is debian 10 so how do i add the dependencies for steamcmd if im even understanding that right.

when i sudo apt-get install steamcmd i get the output
E: Unable to locate package steamcmd

my sources are
deb http://mirrors.linode.com/debian buster main
deb-src http://mirrors.linode.com/debian buster main

deb http://mirrors.linode.com/debian-security buster/updates main
deb-src http://mirrors.linode.com/debian-security buster/updates main

buster-updates, previously known as 'volatile'

deb http://mirrors.linode.com/debian buster-updates main
deb-src http://mirrors.linode.com/debian buster-updates main

to iterate first i installed the missing dependencies

then i changed linode sources except the security ones to non-free, then had the package in the repository

then installed steamcmd
i pathed in steamcmd to home/"user"/serverfiles
(the app id for valheim is 896660)
after this i ran "./vhserver start"
this worked for me


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct