Unable to install a kubernetes cluster on Ubuntu 18.04

Hi everyone,

I have been trying to install a kubernetes cluster on an Ubuntu 18.04 machine.

The problem is that, when I tried to curl the google gpg files, in order to trust the kubernetes apt repository, I got an authorized message.

I then installed kubeadm, kubelet and kubectl manually.

Now, when I try to run kubeadm init, it gets to the point of pulling the k8s images, I get the same unauthorized message.

I’ve tried everything, from checking tls protocols or certificates.

Does anyone have an idea on what could be wrong?

Thank you.

1 Reply

Linode Staff

There was a short period of time right around when you created this question wherein Google's API was blocking requests from IPv6 SLAAC addresses from Linodes in some of our data centers.

The issue has been resolved, and you should be able to connect without problems now.

If this ever happens again, a quick solution would be to either disable your Linode's IPv6 address or force your application to use IPv4. For example, you can add -o Acquire::ForceIPv4=true to an apt command to force it to use IPv4 over IPv6.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct